better marketing that is what really matters. example?
my minilogger has nicer syntax as it does not require class parameter to getLogger()
so less redundancy and no need to do this awaful redundancy
(and that is typical pattern in code that uses Log4J):
public class Xxxxxx {
private static Logger logger = Logger.getLogger(Prunable.class);
it is hardly if i have to chase for bugs when i my class logger gets out
of sync with class name
(look on Productive Environments: Log with log4j)
- typical problem of code redundancy
i.e. class Prunable was used as template to create Xxxx but logger is still
reporting for Prunable - it may be good but it may be also a mistake
and definitely it is better to declare intention with your code:
public class Xxxxxx {
private static Logger logger = Logger.getLogger();
no confusion here: Logger works for containing class